WPS Engine for PostgreSQL

データエンジンモジュール

WPS Engine for PostgreSQL

PostgreSQL データベースへの接続

WPS Engine for PostgreSQL モジュールで、バージョン9(とそれ以降)の PostgreSQL データベースへの接続が可能になりました。

アクセスのタイプ 対応しているかどうか
読み はい
書き はい
更新 はい
テーブルの新規作成 はい
暗黙的なパススルーのサポート はい
明示的なパススルーのサポート はい
バルクロード はい

この PostgreSQL 用の WPS エンジンは、 PostgreSQL 自身の libpq API を使用して PostgreSQL データベースへ接続します。

依存関係と使用方法

WPS Engine for PostgreSQL は、下の表で対応しているプラットフォームでのみの使用になります。

プラットフォーム 対応しているかどうか
System p (POWER) 上の AIXいいえ
ARM 上の Linuxはい
System p (POWER) 上の Linuxはい
x86上の Linuxはい
x86上の macOSはい
SPARC 上の Solarisいいえ
x86上の Solarisはい
x86上の Windowsはい
メインフレーム System z 上の Linuxはい
System z 上の z/OSいいえ

その他のデータエンジンモジュール