WPS Engine for Greenplum

データエンジンモジュール

WPS Engine for Greenplum

Greenplum データベースへの接続

WPS Engine for Greenplum モジュールで、 Greenplum データベースへの接続が可能になりました。

アクセスのタイプ 対応しているかどうか
読み はい
書き はい
更新 はい
テーブルの新規作成 はい
暗黙的なパススルーのサポート はい
明示的なパススルーのサポート はい
バルクロード はい

この Greenplum 用の WPS エンジンは、 libpq API を使用して Greenplum データベースへ接続します。

依存関係と使用方法

WPS Engine for Greenplum は、下の表で対応しているプラットフォームでしか使用することはできません。

プラットフォーム 対応しているかどうか
System p (POWER) 上の AIXはい
ARM 上の Linuxいいえ
System p (POWER) 上の Linuxいいえ
x86上の Linuxはい
x86上の macOS * はい
SPARC 上の Solarisいいえ
x86上の Solaris * はい
x86上の Windows * はい
メインフレーム System z 上の Linuxいいえ
System z 上の z/OSいいえ

* macOS、Solaris on x86、Windows 上のこのインターフェースはこのプラットフォーム上の64 bit 版のドライバーが無いため、32 bit 版 WPS のみが対応しています。


その他のデータエンジンモジュール